Outbound Call Showing Different Number

Incident Report for Retell AI

Resolved

March 3rd: we started to resume Twilio outbound calls with some accounts
March 9th: we are resuming Twilio outbound calls across the platform
Posted Mar 09, 2025 - 20:00 PDT

Monitoring

Recently, we've encountered activity from bad actors. As we conduct a thorough investigation into platform-level KYC, our Twilio account has been temporarily restricted from making outbound calls.

Current Behavior:

1. Outbound dialing with Retell numbers will display a different number and will temporarily fall back to preassigned numbers from Telnyx.

2. Inbound calls to Retell numbers remain functional. However, if an agent initiates a call transfer, a preassigned Telnyx number will be used for the transfer.

Note: SIP REFER with transferee's number is currently experiencing issues with Retell numbers. If you use call transfer, the caller ID will always display the Retell phone number instead of the transferee’s number.

Solutions for Full Control Over Outbound Dialing Numbers:

1. (Recommended) Please use Custom Telephony to connect your own numbers. For more details, visit: https://docs.retellai.com/deploy/custom-telephony.

2. We will soon add an option to purchase Telnyx numbers directly through our platform.

3. For future migration, we will provide documentation to help users transfer existing Retell phone numbers to their own Twilio or telephony accounts.


Our team is working diligently to block bad actors from accessing the platform while ensuring telephony availability for our valued users.

We are committed to resolving this issue as quickly as possible. Thank you for your patience and understanding.
Posted Feb 28, 2025 - 06:00 PST
This incident affected: End to End Calling (Telephony).