Telynx - SIP Trunking Service Degradation

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 16:00 PST

Identified

We are currently experiencing service degradation affecting SIP trunking through our upstream provider, Telnyx. This may result in call connection issues.

https://status.telnyx.com/
Posted Feb 20, 2026 - 13:43 PST
This incident affected: End to End Calling (Phone Call).