Voice agent switching voices during call

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 10:14 PDT

Monitoring

Starting from around 6:30am, elevenlabs TTS is having a full scale outage: https://status.elevenlabs.io/incidents/01K0YAV1N4W7EZW1BMQCQJ4YJR

Our platform traffic starts to fallback to other providers, and the volume of traffic started to break other TTS providers, and that's why you might have seen voice switching mid call, increased latency or even total silence. We're working with other TTS providers to bring in more capacity to support the fallback, and is monitoring closely on elevenlab's outage updates.

Currently the error rate has returned back to normal. We will be actively following up on this.
Posted Jul 24, 2025 - 08:15 PDT