Inbound calling not connecting

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 08:42 PDT

Monitoring

This has been fixed, we are monitoring.
Posted Jul 29, 2026 - 08:39 PDT

Identified

The issue was identified as a datacenter issue from underlying telephony provider, where 2 out of 3 datacenters failed to deliver webhook to Retell backend server.
Posted Jul 29, 2026 - 08:35 PDT

Investigating

We identified that certain number's inbound is not connecting, investigating. Outbound is not impacted.
Posted Jul 29, 2026 - 07:55 PDT
This incident affected: End to End Calling (Phone Call).