Multilingual transcription issues

Incident Report for Retell AI

Resolved

The issue appears to be resolved and multilingual transcription is recovering. We'll keep monitoring to ensure stability.
Posted Jan 22, 2026 - 15:48 PST

Investigating

We're aware of issues affecting multilingual transcription and are actively investigating.
Posted Jan 22, 2026 - 15:37 PST
This incident affected: End to End Calling (Web Call, Phone Call).