Some inbound calls failing to connect

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 15:22 PDT

Monitoring

Service should be back to normal. We are continuing to monitor to ensure stability.
Posted Aug 07, 2026 - 15:16 PDT

Identified

Due to issues with an upstream provider, we are seeing connection issues for a portion of inbound calls. This is not widespread.
Posted Aug 07, 2026 - 14:55 PDT
This incident affected: End to End Calling (Phone Call).