Phone call not connecting

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 16:03 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 14, 2025 - 15:28 PDT

Monitoring

The fix has been applied and phone calls are back to normal at the moment, we are keep monitoring.
Posted Jul 14, 2025 - 15:28 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 14, 2025 - 15:25 PDT

Identified

Telephony provider confirmed that this is related to an outage with Cloudflare DNS, which they use in certain internal components. A change is being applied to mitigate.

related incident: https://www.cloudflarestatus.com/incidents/28r0vbbxsh8f
Posted Jul 14, 2025 - 15:23 PDT

Investigating

Our telephony SIP provider confirmed there's an ongoing outage that led to phone call not connecting.
We are escalating now, and is trying potential workarounds.
Posted Jul 14, 2025 - 15:20 PDT
This incident affected: End to End Calling (Telephony).