Certain calls are not being picked up in time

Incident Report for Retell AI

Resolved

This incident has been resolved. It was due to a connection issue in one of the data centers for the telephony provider. We are adding more fallback routes there.
Posted May 28, 2026 - 09:30 PDT

Investigating

Certain calls are experiencing no pickup, or being dropped due to web socket connection issues. We are investigating now.
Posted May 28, 2026 - 08:00 PDT
This incident affected: End to End Calling (Web Call, Phone Call).