Dashboard Down
Incident Report for Retell AI
Resolved
Vercel server was down for 1 hour, back to normal now. No idea why.
Posted Oct 13, 2024 - 09:11 PDT
Identified
Retell Dashboard is down. Inbound agents and API endpoint working as usual.
Posted Oct 13, 2024 - 08:15 PDT
This incident affected: Dashboard.