AWS outage causing some login issues, and history and analytics issue. Calls are NOT impacted.

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:42 PDT

Monitoring

The AWS outage has been resolved. We are going to backfill analytics, and keep a close eye on it.
Posted Oct 20, 2025 - 16:51 PDT

Identified

Starting from Oct 20 1am PST, the AWS outage has caused some login issues, and call history and analytics issues.
Regular calls are NOT impacted.
Once the AWS outage is over, we will backfill the analytics.
Posted Oct 20, 2025 - 12:02 PDT
This incident affected: Dashboard.