Platform voice Grace and Nico not working

Incident Report for Retell AI

Resolved

The issue is resolved now
Posted Jun 12, 2026 - 09:44 PDT

Investigating

The platform voice, Grace and Nico, are not working
Posted Jun 12, 2026 - 00:30 PDT
This incident affected: End to End Calling (Web Call, Phone Call).