Call Transfer Failures

Incident Report for Retell AI

Resolved

This incident has been resolved. We are working internally to add more test cases to prevent this from happening.
Posted May 19, 2025 - 18:47 PDT

Monitoring

Due to a technical issue, some calls experienced failures when performing cold transfers with agent numbers or warm transfers. This led to unexpected call drop-offs during transfer attempts.

A fix is currently being deployed to resolve the issue.

Impact window: May 19, 1:44 PM PDT – ongoing
Posted May 19, 2025 - 17:33 PDT
This incident affected: End to End Calling (Telephony).