Telnyx inbound calls choppy

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 14:15 PDT

Monitoring

The choppy issue seems resolved. We will keep monitoring and will help telephony partners find the root cause to help them prevent this from happening again.
Posted Jun 13, 2025 - 12:51 PDT

Investigating

We have identified that starting from 9:30am PDT, all Telnyx inbound calls are very choppy.
With the current investigation, it indicates that this is a telephony issue, and we have escalated to our telephony carriers and partners, awaiting their response and fix.

Telnyx outbound is working normally.
Twilio inbound and outbound is working normally.

If you are using Telnyx inbound, we recommend you to switch to a Twilio number in the meantime while the Telnyx and other telephony partners address this issue.
Posted Jun 13, 2025 - 10:15 PDT
This incident affected: End to End Calling (Telephony).