Inbound and Web call not connecting

Incident Report for Retell AI

Resolved

This incident has been resolved.
Posted May 21, 2025 - 21:51 PDT

Identified

The issue is identified and is being mitigated. A fix is rolling out.
Posted May 21, 2025 - 21:34 PDT
This incident affected: End to End Calling (Web Call, Telephony).