Outbound Calling Service Degradation

Incident Report for Retell AI

Resolved

The issue has been fixed
Posted Jan 09, 2026 - 02:26 PST

Monitoring

The issue should have been resolved, we are closely monitoring the status.
Posted Jan 09, 2026 - 02:17 PST

Identified

The root cause has been traced to our telephony stack provider.
The issue has been escalated to their support team, who are actively triaging the incident.
Posted Jan 09, 2026 - 01:58 PST

Investigating

Outbound calls are currently experiencing issues. Some users report receiving multiple calls from a single dial attempt, or agents being unable to hear audio. We are investigating the root cause.
Posted Jan 09, 2026 - 00:30 PST
This incident affected: End to End Calling (Phone Call).