Call/chat history, analytics and QA dashboard down

Incident Report for Retell AI

Resolved

The issue has been fixed and all services are back to working.
Posted May 25, 2026 - 14:40 PDT

Identified

We are rolling out a fix to direct the traffic to our database replica while the provider is investigating the issue.
Note that no call or chat data were lost.
Posted May 25, 2026 - 14:33 PDT

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 14:13 PDT

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 14:12 PDT

Investigating

Due to a database outage, call/chat history, analytics and QA dashboard down are currently completely down. We are working with the database team to fix the issue.
Posted May 25, 2026 - 14:09 PDT
This incident affected: Features (Alerting, Analytics, QA) and Dashboard.